IPTV (live TV kijken) met Amino kastje werkt plots niet meer

Sinds gisteren werkt het live TV kijken via de Amino kastjes (ik heb er twee) niet meer. Er is verder in huis aan het netwerk helemaal niets veranderd. Er is een melding van een storing met Begintijd** : 22 juli 14.00 en Eindtijd** : 22 juli 14.50 maar toen keek ik geen TV en toen ik het later die middag probeerde werkte het niet.
TV pauzeren en weer starten en dus met een paar seconden vertraging kijken werkt wel. Opnames bekijken ook. Live TV op de laptop bekijken werkt ook. Het is alleen het IPTV signaal (in de Fritzbox te zien met bruin, tegenover gewoon internet verkeer in geel) dat gewoon niet binnenkomt.
Ik heb de Fritzbox opnieuw opgestart. Ik heb de Amino kastjes opnieuw opgestart. Niets helpt.
Ik heb gezien dat er van 2 jaar geleden ook zo’n meldingen waren… met onduidelijke stappen richting een oplossing. Maar ik heb een situatie hier thuis die perfect werkte tot vrijdagmiddag, en dan plots niet meer. Dus er is buiten mijn thuisnetwerk iets kapot… maar wat? Zijn er nog mensen met dit probleem? (Ik zit zelf in Eindhoven, misschien dat er nog lokale gebruikers zijn met dit probleem?)

Misschien had ik vorige week donderdag/vrijdag iets vergelijkbaars. Kanalen 1 tm/ 10 stilstaand beeld en haperingen, kanaalnummers daarboven deden het wel.
Helpdesk gebeld, duurde wel lang voordat ik iemand aan de lijn had: Dit was bekend probleem, iets met dat geheugen van FritzBox dat volloopt. Eerste keer sinds dat ik TV bijn Freedom heb.
Oplossing: stroom er af en na een tientalseconden er weer op.

Misschien werkt dat bij jou ook. Stroom eraf/erop is mogelijk iets anders dan een reboot. Weet niet wat je precies bedoelt met ‘opnieuw opgestart’.

Helaas, de tip van de FritzBox uitzetten en na 20 seconden weer aanzetten had ik al gezien en gevolgd en dat maakte geen enkel verschil. Maar mijn probleem is ook niet hetzelfde. Ik heb op geen enkel kanaal beeld. Geen haperingen of stilstaand beeld maar helemaal niets.
En als je in de Fritzbox bij Internet->Online Monitor kijkt dan zie je bij de download een geel deel voor gewoon Internet en een bruin deel voor IPTV. Het bruine deel ontbreekt nu helemaal. Er komt helemaal niets meer binnen van IPTV.

Het lijkt erop dat jouw multicast een probleem heeft Dat verkeer loopt via VLAN4.
de Begin gemist Streaming en later terug kijken kanalen (Dit worden ook de OtT Over the Top kanalen genoemd) lopen via het Internet.

Een eventuele switch tussen Fritzbox en STB kan ook nog issues geven.

Geen idee wat dat betekent of wat dat voor een oplossing zou kunnen betekenen. Bij mij zit alles, ook de Amino’s op hetzelfde LAN als de rest van de computers en krijgen een IP adres van de FritzBox in dezelfde range. Ook met een 24 poorts switch ertussen. En dat werkt op zich prima. (Maar de Amino’s zelf zijn om andere redenen gewoon slecht, maar dat is hier niet het probleem)
Paul heeft niets in zijn netwerk gewijzigd.
Dus mij is niets bekend van VLAN whatever. Misschien kan Paul er wel wat mee, maar mij zou het het helemaal niets zeggen.
Misschien wat nadere uitleg zou behulpzaam kunnen zijn.

VLAN 4 klopt maar voor een klant met een Fritz!box is dat niet van belang. De Fritz!box zet het verkeer op het interne netwerk zonder VLAN4 en als gewoon LAN verkeer.

1 like

Er zit geen switch tussen de Fritzbox en de Amino. Ik heb alle ethernet kabels uit mijn Fritzbox uitgetrokken en alleen maar een rechtstreekse kabel van de Fritzbox naar een Amino kastje gelegd, zodat er niets de verbinding kon storen. Dan de Fritzbox 20 seconden van de stroom afgehaald. Dan de Amino ook 20 seconden van de stroom afgehaald. Alles is dus prima gereset en er is niets dat nog kan storen maar het IPTV signaal komt nog steeds niet door. Ik vrees dat de geplande onderbreking van de TV op 22 juli van 14:00 tot 14:50 die bij de “opgeloste” meldingen staat toch gewoon nog steeds verder duurt…

Dat bruine deel, wat je ziet in de fritzbox is de live tv voor de kastjes.
Dat heeft een perfecte internet verbinding nodig.
Er kan dus ook iets in de verbinding naar jouw toe stuk zijn gegaan.
Dat bruine gedeelte is virtueel, een ander netwerk dan de rest van het internet.(VLAN)
Ze zijn de 22e net na het middaguur wel aan het sleutelen geweest met het netwerk.
Er was op alle storingen ook een piek te zien bij Freedom en Tweak.
Het internet, was er hier ook een paar minuten af.

Ehm, dit is verwarrend maar het lijkt erop dat VLAN 4 loopt tot de Amino…of juist niet!?

Instellingen voor televisie

Om de algemene informatie over televisie te lezen, klik hier.

    Router moet DHCP-requests doen op VLAN 4 voor TV.
    Er moet NAT worden toegepast voor verkeer over VLAN 4.
    Er moeten static routes worden gezet naar 10.10.0.33/32, 185.24.175.0/24 en 185.41.48.0/24 over het op VLAN 4 verkregen gateway IP. Deze routes worden ook via DHCP optie 121 doorgegeven. (Let op. Heb je een verbinding via het glasvezel Helmond netwerk of Fiber Operator? Dan hoef je geen statische routes in te stellen).
    De settopboxen hangen in het normale LAN.
    IGMP snooping of proxying moet worden toegepast op VLAN 4.
    RTSP connection tracking module moet ingeschakeld worden mits beschikbaar. Bij een enkele TV ontvanger kan er ook een Destination NAT regel worden ingesteld.

@Erik: “Er kan dus ook iets in de verbinding naar jouw toe stuk zijn gegaan.” Dat denk ik dus ook, want hier in huis is absoluut niets veranderd. Ik vermoed dus dat er een storing is, waar waarschijnlijk tijdens het weekend niets aan gedaan wordt…

@pauldebra
Ik denk dat je maandag, maar eerst eens met de helpdesk moet praten.
Je zou nog support data van de fritzbox kunnen genereren.
Onderstaande kom je zo, door “vlan 4” te zoeken.
Verderop staan de logboeken, van de laatste activiteiten.

@anon54082171
De tv zit onder de motorkap.
Zie wel iets dat met dit begint.

2: name iptv (attached)
2: sync_group: sync_fiber
2: iface wan RBE/18/dsl xx:xx:xx:xx:xx:xx stay online 1 vlan 4 prio 5
2: IPv6: off
2: IPv4: native
2: IPv4: connected since 2022-07-22 12:49:26 (setup time 1 secs) (connect cnt 1)
2: IPv4: disconnect prevention disabled

Over support data.
Er is daarvoor een een handigheidje.
Als je de pushmail in de fritzbox actief hebt.
Is bellen naar *99# voldoende om support data op de mail te krijgen.

VLAN4 (TV) / VLAN6 (INTERNET PPPoE) lopen uitsluitend op het WAN (tot de router).
De Router zal ze daarna doorsturen naar het LAN (of de LAN’s…) standaard Routering al of niet met NAT.

Voor VLAN4 wordt Multicast gebruikt, en voor het doorsturen ervan naar het LAN is een Multicast Proxy nodig.
Die multicast Proxy zorgt ervoor dat abonnementen (de gekozen stream) aangezet wordt naar de upstream Multicast router. (en die weer tot de originele media server). Dat is het IGMP protocol (waarvoor switches onderweg IGMP snooping nodig hebben).
Multicast abonnementen moeten elke 5 minuten verlengd worden.

Bij multicast is maar een media server nodig die stuurt een pakket uit, op elke router onderweg wordt het signaal naar meerdere uitgangen gestuurd zoals via de abonnementen is aangevraagd. (Bij geen aanvragers is er geen verkeer bij 1.000.000 aanvragers is elk pakket maar een maal verzonden door de mediaserver.).

1 like

zelfde probleem hier.
Wat mij opviel is dat bij het wisselen van zender, het amino kastje automatisch in “PAUZE TV” stand komt. Elke keer als je van zender wisselt.
Als je daarna op het PLAY knopje drukt op de afstandsbediening gaat ze zender wel lopen.

Dit probleem zit alleen in het amino kastje. De Canal Digitaal app voor android werkt bij mij wel.

Bij live kijken is de werking van de Amino anders dan via Android/iPad/Web-TV.

De Amino krijgt een stream binnen en kan niet aangeven, ik heb niets binnen gekregen (UDP protocol).

Met de andere andere manieren en terug/opname kijken gaat via het TCP protocol en die kan aangeven dat een packet opnieuw gezonden moet worden.

UDP is ideaal om streams zenden naar veel ontvangers tegelijkertijd te zenden. Als er wat mis gaat dan helpt opnieuw “afstemmen” op de “zender”.

Dat de Amino in de pauze stand gaat is bijzonder.

Hoera, eindelijk nog iemand met ongeveer dit probleem.
Het zou lastig zijn om de Helpdesk ervan te overtuigen dat er iets mis is wanneer ik de enige ben met het probleem…
In elk geval is de situatie nog steeds onveranderd.
Wie weet is er verderop in het netwerk zo’n “multicast proxy” of “upstream Multicast router” kapot…

Dat is helemaal waar voor UDP zelf. Maar op de applicatie-laag gaat de Amnio wel degelijk vragen om ‘reparatie verkeer’ als de multicast-UDP-stream niet goed loopt. Dat verkeer kan de stream ten dele repareren.

Dus het is wel te zien dat en waar multicast mis gaat. Sinds enige tijd wordt die info uit een beperkte set van de geïnstalleerde kastjes ook gebruikt om problemen te signaleren en dat heeft ook al tot oplossingen geleidt.

Maar ja daar gaat altijd te veel tijd overheen en daar heb je als klant niet zoveel aan als je niet kan kijken :unamused:

In Multicast stream kan niet echt om een retransmit gevraagd worden, De retransmit zou immers naar ALLE abonnees gaan.
Om de X tijd (enkele tiental seconden) wordt er Full Frame (geen compressie) verzonden.
Tussen de full frames worden er alleen veranderde delen doorgegeven. als die (deels) missen ontstaan er “blokjes” in het beeld.

Als vanaf de keuze van een zender de transmissie niet start dat gaat het abonneren op de stream dus mis (IGMP protocol).
Idd. iets met de multicast proxies.

1 like

Je kan inderdaad wel eens korte onderbrekingen hebben als er iets uit de stream gemist wordt. Maar… de stream komt dan wel gedeeltelijk binnen en in de Fritzbox monitor moet je dan het “bruine” gedeelte van de IPTV stream zien. In mijn geval komt er helemaal niets binnen: er is geen bruine data stream te zien in de monitor, allen de gele stream van andere applicaties (op andere apparaten).

Het reparatie-verkeer voor de multicast-stream is unicast :slight_smile:

Data-reductie van videostreams werkt inderdaad door periodiek het hele plaatje (I-frames) te sturen om vervolgens de veranderingen middels zgn. P-frames (nieuwe stukjes) of B-frames (verschuivingen) te sturen. De data van de plaatjes is gecomprimeerd en gereduceerd. Het reparatie-verkeer stuurt de missende data en als dat niet lukt dan komen er inderdaad blokjes of gewoon geen frame.

Ik denk dat iets in die richting in dit geval wel aan de hand is. Ik had gisteravond al intern commentaar gegeven op het ticket van @pauldebra. Maar eh mijn reactie was een aanvulling op de post van @anon54082171 :slight_smile: