Fritz-box IPv6 en eigen hosting server (nextcloud Joomla)

Goedendag iedereen,

Vraag mbt gebruik IPv6 en webserver (multiple vhosts)

Ik probeer in alle macht IPv6 werkend te krijgen maar loop klem met het AAAA record, wanneer ik het externe IPv6 gebruik (WhatsMyIP) als AAAA record dan krijg ik een foutmelding van internet.nl dat deze niet bereikbaar is.

Mijn huidige IPv4 configuratie met meerdere 10.10.10.xxx adressen voor routing van de vhosts functioneert prima, momenteel probeer ik eenzelfde configuratie met IPv6 te realiseren met interne IPv6 adressen voor de vhosts fe02::xx etc. maar internet.nl blijft aangeven dat het AAAA record met IPv6 adres onjuist is.

Wanneer ik bij netwerk in de fritz-box kijk staan daar bij de individueel geconfigureerde IPv4 configuratie ook 12 IPv6 adressen zonder verdere duiding bij.

Wat zou voor mij het juiste IPv6 adres zijn dat ik voor het AAAA record moet gebruiken?

Alvast bedankt.

Fred

[:warning: verwijderd: fout antwoord].
Welke adressen kun je selecteren?

Zie ook Wikipedia: Internet Protocol versie 6 - Wikipedia

Heb de fe00 adressen verwijderd uit de server routing en nu is alles bereikbaar maar krijg nu de melding dat het IPv6 adres gebruikt in het AAAA record onbereikbaar is, is het correct om het IPv6 adres verkregen via MyIP 1op1 kan worden gebruikt als AAAA record of klopt dat niet? Terwijl een eerdere test met dat IPv6 adres succesvol was op internet.nl

In de webinterface van de Fritz!Box kan je zien welke IPv6 prefix je hebt gekregen. Dit kan je zien via Internet → Online Monitor en dan staat daar de IPv6 prefix genoemd. Iets als 2a10:3781:xxxx::/48 .
En je moet dan ook zorgen dat het systeem in het interne netwerk een adres uit die reeks krijgt. Als dat gelukt is moet je ook nog een Port forward/ Port Sharing doen om de (IPv6) firewall in de Fritz!Box open te zetten.

1 like

Heb je het nu over fe00 of over fe02 of over fe80 adressen?
De fe80 adressen moet je gewoon actief laten op je systeem. Er moet nog wel een publiek IPv6 adres aan toegevegd worden.

1 like

Enkel de eerder door mijzelf gecreëerde fe00 adressen verwijderd, heb zojuist het IPv6 adres uit de Fritzbox internet>online monitor overgenomen in de DNS AAAA records maar blijf de melding krijgen van internet.nl dat dat adres onbereikbaar is…

Je zal het IPv6 adres van de betreffende webserver in je netwerk, zoals dat van buitenaf zichtbaar is, moeten opnemen en ook in de fritzbox de foward daarvoor moeten toestaan.

Vaak eindigt het IPv6 adres van het apparaat waarop je server staat met het mac adres van het betreffende apparaat. Het begin van het IPv6 adres is dan de prefix die je van freedom hebt ontvangen.

Als in het lijtsje met IPv6 adressen kijkt die je server heeft gekregen vind je dat adres wel.
Kijk in je frotz Box naar ‘Home network’, ’ Network connections’ en klik dan op het potloodje achter jouw server. Daar zie jet het adres dat begint met 2a10 van de server, dat moet je dan volledig in het AAAA record zetten.
Ook moet je dan via ’ Port sharing’ de betreffende poort op IPv6 open zetten voor dat adres (meestal dan 80 of 443)

Het is me nog niet duidelijk of je op het systeem waar nextcloud/joomla draait ook een publiek IPv6 adres, uit de reeks die de Fritz!Box noemt, hebt toegevoegd.
En het adres 2a10:3781:xxxx::/48 is NIET het juiste adres.
Ik zie nu dat er nog op een andere plek iets over de IPv6 prefix staat. Namelijk in Home Network → Network → Network Settings (tab) → IPv6 Settings. Daar zie je onderaan de pagina “IPv6 Prefixes Used”. En dat eerste deel moet je gebruiken om een IPv6 adres voor je server te maken.
Daarna zou je vanaf een ander systeem, in hetzelfde netwerk, het IPv6 adres moeten kunnen pingen.

Als je prefix 2a10:3781:xxxx::/48 je prefix is, en je LAN nummer 1 heeft gekregen…
Dan zou je adres 2a10:3781:xxxx:1::1 kunnen zijn. t/m 2a10:3781:xxxx:FFFF:FFFF:FFFF:FFFF:FFFF …
Je kan dat evt. statisch vastleggen, op de server, of via DHCPv6 uitdelen of…

Je gekozen adres moet je in DNS vastleggen. Je kan op de server overigens 10-tallen IPv6 adressen gelijktijdig gebruiken, gebruik voor een server nooit het automatisch bepaalde of uitgedeelde random adres, je blijft van DNS updates doen.
(Als je Privacy mode instelt dan gebruikt je systeem zo wie zo een random adres als source dat regelmatig wisselt).

Portforward/NAT is ABSOLUUT niet van toepassing. Toestaan in een Firewall is wel van toepassing

Geen last van, het door de fitzbox uitgedeelde IPv6 adres is gebaseerd op het mac adres van de betreffende machine, die is vast.

Inderdaad portforward niet, maar een poort van die machine beschikbaar maken voor bereik vanaf buiten op het IPv6 adres van die machine op de fritzbox moet wel. Dat gaat op de fritzbox via hetzelfde menu als waar je ook portforwards instelt voor IPv4.

Heb IPv6 adres zoals vermeld in portforwarding overzicht (2a10:3781:xxxx:1:fabc:12ff:fe55:9030)getest in een DNS AAAA record zonder succes, de server blijft onbereikbaar.

Misschien even alles op een rijtje? @Fred-Internet , als het goed is heb je de volgende dingen:

  • een public IPv6 range (die vastgezet is door Freedom? bv 2a10:3781:xxxx::/48 )
  • een public IPv6 adres uit die range dat toegekend is aan je modem (bv 2a10:3781:xxxx::1 )
  • een public IPv4 adres (dat vastgezet is door Freedom?) (bv 198.51.100.34 - let op dit is niet een echt werkend adres :slight_smile: )
  • een domein, bv fred-internet.nl
  • een interne IPv6 range ( fc00::/7* dus fc02::… is wel degelijk een correct intern adres! Ik heb hier een fout heb gemaakt in mijn eerdere antwoord. Excuus!)
  • geen adressen uit de fe80::/64 of 169.254.0.0/16 ranges: deze worden gebruikt wanneer er geen config en geen dhcp is)
  1. Maak nu eerst je AAAA record (bv linux.fred-internet.nl) aan met het public IPv6 adres (2a10:3781:xxxx::1)
  2. In de Fritzbox interface ga je naar Internet > Toegang verlenen > Poortvrijgaven apparaat.
  3. Kies hier het apparaat (bv linux-server). Als het een IPv6 adres heeft moet dat verschijnen in de IPv6-interface-ID velden.
  4. Kies onderaan nieuwe vrijgave en selecteer de service (bv HTTPS port 443)
  5. Nu zou het (weer) moeten werken.

Hier is ook de uitleg van AVM te vinden, met geavanceerder opties.

EDIT: de service die je wilt benaderen moet natuurlijk wel te benaderen zijn via port op het interne adres. Dus stel dat je linux-server uit het voorbeeld hierboven hebt ingesteld, dan moet
https://[fe80::xxxx:yyyy::12]/ (voorbeeld adres) ook werken vanaf een laptop die binnen in het netwerk zit. Als dat niet werkt kan de poortvrijgave niet zoveel.

Update, IPv6 tot in de ethernet van de tux box nu voor elkaar, alleen mijn tux box mist de correcte configuratie naar de webserver toe, alle vhosts hebben *:80 [::]:80 en hetzelfde voor ssl configuratie, waar het knelpunt nu zit ben ik nog aan het uitzoeken, tips en hints zijn ook hier meer dan welkom… :+1:
(Ifconfig em2 geeft nu een IPv6 adres)

1 like

Maar wel poort 443 voor de SSL configuratie hoop ik…

2 likes

Na hoor ook 443 is op orde bedankt voor de tip​:+1::point_down:

1 like