[Handleiding:] configureren van OpenWrt

Ik gebruik geen SQM, maar trek 210Mbps uit mijn VDSL2 verbinding in de download richting. Op de glas verbinding die qua abbonnement maar 100Mbps is haal ik up en down tegelijkertijd met gemak die maximum zonder ook maar enige belasting te zien:

2020-11-04 15:01:29 (13.1 MB/s) - ‘/dev/null’ saved [1048576000/1048576000]

Als ik wireguard gebruik wordt het een ander verhaal, en blijf ik hangen rond de 30Mbps omdat de cpu het te zwaar krijgt.

1 like

GL.iNet?

Ik heb een GL-MiFi voor onderweg, en op m’n werk heb ik een lading GL-AR150’s draaien als AP’s.

Ze hebben wel een rare GUI er overheen gezet, al is LuCI ook beschikbaar. Maar ik flash altijd gewoon vanilla OpenWrt.

Die kende ik nog niet, redelijke prijsklasse, dual core 1Ghz en 1GiB geheugen dus dik in orde. Bedankt!!!

1 like

Niet al hun routers draaien OpenWrt, maar heel veel wel. Hier heb je een lijst op de OpenWrt-Wiki. Er zitten zelfs quadcore devices tussen.

I use the GL-B1300 flashed with stock OpenWRT. Works very well.

Some people complain about the WiFi performance but I use a separate AP so can’t comment on that, but as a router between Ethernet -> PPPoE I have no complaints.

1 like

Wat dacht je van het Europese product van CZNIC: Turris Omnia en Turris MOX: https://www.turris.com/en/
OpenWRT wordt bij hun alleen op BTRFS opgeslagen zodat ze upgrades in een transactie kunnen verwerken.
(“unbrickable”).

1 like

@Kevin

Goedemiddag,

Ik heb jouw tutorial gevolgd om te kijken of ik mijn WRT3200ACM met Openwrt kan gebruiken voor Freedom. Momenteel zit ik nog bij xs4all maar de instellingen leken op die van freedom. Ik heb deze instructie erbij gelegd [OpenWrt Wiki] ISP Configurations . Ik heb een Genexis FTU welke op de website van freedom staat dat dit ook en NTU is.

Echter ik krijg connection attempt failed en ik zie bij de switch vlan geen poort aanwijzing (zie screenshots) . Wat mis ik ? Er wordt geen verbinding wordt gemaakt (en ik ben bang dat dit dan ook met Freedom gebeurd) poort 4 is de aansluiting naar de FTU/NTU

Ik heb dan maar ook de 5490 bij de nieuwe aansluting van Freedom mee besteld. :slight_smile:


Er zijn connectie providers die geen VLAN6 untagged aanleveren als er geen TV (VLAN4) wordt afgenomen.
je kan proberen of pppoE over de ruwe eth0 kan.

En je plugt je NTU in in LAN4 in plaats van WAN dus? Als je debug meegeeft aan pppd, kan je dan eens de output van logread laten zien?

Want aan de GUI te zien, is er niets ingeplugd, dus dit zou ook al iets lulligs kunnen zijn als een kapotte ethernetkabel.

Ik heb instellingen verandert naar de wan poort …eth1.6. Ik dacht dat dit eerst het probleem was daarom naar LAN poort 4 . Dit laat de GUi nog steeds niet zien dat er een kabel in de WAN poort zit. Dit zit mij dan niet lekker. Oh en meerdere kabels geprobeerd omdat uit te sluiten

Gezien de instructie van Freedom en Xs4all nagenoeg gelijk waren en beide eigen modems aan bieden ga ik er van uit dat ook zei untagged VLAN6 aanbieden (dit kan mij fout zijn )
P.S als Xs4all het probleem is dan laat ik het rusten tot dat de aansluiting van Freedom er is.

De dump van logread

Citaat Wed Feb 17 16:28:00 2021 daemon.debug pppd[15753]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Wed Feb 17 16:28:00 2021 daemon.debug pppd[15753]: dst ff:ff:ff:ff:ff:ff src 60:38:e0:cd:9d:28
Wed Feb 17 16:28:00 2021 daemon.debug pppd[15753]: [service-name] [host-uniq 89 3d 00 00]
Wed Feb 17 16:28:03 2021 daemon.info procd: Instance sysntpd::instance1 pid 2302 not stopped on SIGTERM, sending SIGKILL instead
Wed Feb 17 16:28:05 2021 daemon.warn pppd[15753]: Timeout waiting for PADO packets
Wed Feb 17 16:28:05 2021 daemon.err pppd[15753]: Unable to complete PPPoE Discovery
Wed Feb 17 16:28:05 2021 daemon.info pppd[15753]: Exit.
Wed Feb 17 16:28:05 2021 daemon.notice netifd: Interface ‘wan’ is now down
Wed Feb 17 16:28:05 2021 kern.info kernel: [ 6086.713649] mvneta f1070000.ethernet eth1: Link is Down
Wed Feb 17 16:28:05 2021 daemon.notice netifd: Interface ‘wan’ is disabled
Wed Feb 17 16:28:05 2021 daemon.notice netifd: Interface ‘wan’ is enabled
Wed Feb 17 16:28:05 2021 daemon.notice netifd: Interface ‘wan’ is setting up now
Wed Feb 17 16:28:05 2021 kern.info kernel: [ 6086.724626] mvneta f1070000.ethernet eth1: configuring for fixed/rgmii-id link mode
Wed Feb 17 16:28:05 2021 kern.info kernel: [ 6086.732403] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
Wed Feb 17 16:28:05 2021 kern.info kernel: [ 6086.738282] mvneta f1070000.ethernet eth1: Link is Up - 1Gbps/Full - flow control off
Wed Feb 17 16:28:05 2021 kern.info kernel: [ 6086.746219] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
Wed Feb 17 16:28:05 2021 daemon.err insmod: module is already loaded - slhc
Wed Feb 17 16:28:05 2021 daemon.err insmod: module is already loaded - ppp_generic
Wed Feb 17 16:28:05 2021 daemon.err insmod: module is already loaded - pppox
Wed Feb 17 16:28:05 2021 daemon.err insmod: module is already loaded - pppoe
Wed Feb 17 16:28:05 2021 daemon.info pppd[16019]: Plugin rp-pppoe.so loaded.
Wed Feb 17 16:28:05 2021 daemon.info pppd[16019]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Wed Feb 17 16:28:06 2021 daemon.notice pppd[16019]: pppd 2.4.7 started by root, uid 0
Wed Feb 17 16:28:06 2021 daemon.debug pppd[16019]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Wed Feb 17 16:28:06 2021 daemon.debug pppd[16019]: dst ff:ff:ff:ff:ff:ff src 60:38:e0:cd:9d:28
Wed Feb 17 16:28:06 2021 daemon.debug pppd[16019]: [service-name] [host-uniq 93 3e 00 00]
Wed Feb 17 16:28:11 2021 daemon.debug pppd[16019]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Wed Feb 17 16:28:11 2021 daemon.debug pppd[16019]: dst ff:ff:ff:ff:ff:ff src 60:38:e0:cd:9d:28
Wed Feb 17 16:28:11 2021 daemon.debug pppd[16019]: [service-name] [host-uniq 93 3e 00 00]
Wed Feb 17 16:28:16 2021 daemon.debug pppd[16019]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Wed Feb 17 16:28:16 2021 daemon.debug pppd[16019]: dst ff:ff:ff:ff:ff:ff src 60:38:e0:cd:9d:28
Wed Feb 17 16:28:16 2021 daemon.debug pppd[16019]: [service-name] [host-uniq 93 3e 00 00]
Wed Feb 17 16:28:21 2021 daemon.notice netifd: Interface ‘wan’ is now down
Wed Feb 17 16:28:21 2021 kern.info kernel: [ 6102.513819] mvneta f1070000.ethernet eth1: Link is Down
Wed Feb 17 16:28:21 2021 daemon.notice netifd: Interface ‘wan’ is disabled
Wed Feb 17 16:28:21 2021 daemon.notice netifd: Interface ‘wan’ is enabled
Wed Feb 17 16:28:21 2021 daemon.notice netifd: Interface ‘wan’ is setting up now
Wed Feb 17 16:28:21 2021 kern.info kernel: [ 6102.524765] mvneta f1070000.ethernet eth1: configuring for fixed/rgmii-id link mode
Wed Feb 17 16:28:21 2021 kern.info kernel: [ 6102.532553] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
Wed Feb 17 16:28:21 2021 kern.info kernel: [ 6102.538454] mvneta f1070000.ethernet eth1: Link is Up - 1Gbps/Full - flow control off
Wed Feb 17 16:28:21 2021 daemon.err insmod: module is already loaded - slhc
Wed Feb 17 16:28:21 2021 daemon.err insmod: module is already loaded - ppp_generic
Wed Feb 17 16:28:21 2021 daemon.err insmod: module is already loaded - pppox
Wed Feb 17 16:28:21 2021 daemon.err insmod: module is already loaded - pppoe
Wed Feb 17 16:28:21 2021 daemon.info pppd[16223]: Plugin rp-pppoe.so loaded.
Wed Feb 17 16:28:21 2021 daemon.info pppd[16223]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Wed Feb 17 16:28:21 2021 daemon.notice pppd[16223]: pppd 2.4.7 started by root, uid 0
Wed Feb 17 16:28:21 2021 daemon.debug pppd[16223]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Wed Feb 17 16:28:21 2021 daemon.debug pppd[16223]: dst ff:ff:ff:ff:ff:ff src 60:38:e0:cd:9d:28
Wed Feb 17 16:28:21 2021 daemon.debug pppd[16223]: [service-name] [host-uniq 5f 3f 00 00]
Wed Feb 17 16:28:21 2021 kern.info kernel: [ 6102.613667] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
Wed Feb 17 16:28:26 2021 daemon.debug pppd[16223]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Wed Feb 17 16:28:26 2021 daemon.debug pppd[16223]: dst ff:ff:ff:ff:ff:ff src 60:38:e0:cd:9d:28
Wed Feb 17 16:28:26 2021 daemon.debug pppd[16223]: [service-name] [host-uniq 5f 3f 00 00]

De instellingen van XS4ALL en Freedom zijn identiek, dus dat zou het probleem niet mogen zijn. Ik zie hier dat de link wel up komt, maar dat PPPoE discovery faalt. Heb je wel iets ingevuld bij je PAP/CHAP username? Dat mag gewoon fake@freedom.nl zijn, maar er moet wel iets staan zodat de PPPoE intermediate agent werkt.

P.S. Moet je CPU 0 niet uitzetten voor VLAN 6?

Ja ik heb daar inderdaad wat staan met password 1234 zodat er iets staat. Oh ik krijg deze wel de hele tijd Error: Unknown error (USER_REQUEST)

Twee dingen die je nog kunt testen:

  1. Je PC inpluggen op de WAN-poort. Dat gaat uiteraard niet werken, maar zie je dan in de switch GUI wel dat er een kabel is ingeplugd?

  2. Je PC direct aansluiten op de NTU. Zie je daar dan dat de link opkomt? Met NetworkManager op Linux zou je overigens ook vrij eenvoudig PPPoE op een VLAN moeten kunnen instellen, maar het gaat mij er meer om dat de ledjes wel gaan knipperen.

De Unknown Error: User_Request krijg je in LuCI volgens mij altijd wanneer pppd faalt.

  1. WAN poort wordt zichtbaar met kabel ingeplugd
  2. Lampjes branden en knipperen zowel op de FTU/NTU als Windows geven een verbinding (geen IP etc)

Fritzbox heeft overigs nergens last van die kan communiceren met de FTU. Waarom openwrt dan niet ?

Misschien link speed negotiation? Heb je een oude 10/100-NTU soms?

Denk het niet want ik heb momenteel 500 up en down …

Ik zie het zo snel even niet. Kan je eens je volledige /etc/config/network posten?

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fdb5:5175:0d88::/48’

config interface ‘lan’
option type ‘bridge’
option ifname ‘eth0.1’
option proto ‘static’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option ipaddr ‘192.168.178.2’

config interface ‘wan’
option proto ‘pppoe’
option ipv6 ‘auto’
option pppd_options ‘debug’
option ifname ‘eth1.6’
option username ‘fake@freedom.nl’
option password ‘1234’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option vid ‘1’
option ports ‘1 2 3 5t’

config switch_vlan
option device ‘switch0’
option vlan ‘3’
option vid ‘6’
option ports ‘4t 5t 6t’

Als ik het goed lees zegt mijn config Vlan 3 …maar die zie ik niet in de GUI

Verander die 3 eens in een 6, en doe dan service network restart?

Je moet ook eigenlijk nooit GUI’s gebruiken. :wink: