[Handleiding:] configureren van OpenWrt

Inderdaad Kevin niet ik

@Kevin
Oeps, Ik dacht dat je Michael had aangeslingerd.
Dus bij deze nog een keer:
Kevin for president !! :sunglasses: :yum: :+1: :+1: :+1:
Heel hartelijk bedankt.

1 like

Heeft iemand al eens een DD-WRT router succesvol ingesteld?

Hoi
Heel erg bedankt hiervoor. Ik ben nieuw bij Freedom, en ben net klaar met het opzetten van v6 op mijn eigen Ubiquiti Edgerouter X SFP. Ik gebruik een NTU, niet de glasvezel-SFP.

Deze instructies, samen met deze https://blog.daknob.net/setting-up-edgemax-devices-for-ote-ipv6/, hebben me geholpen V6 te krijgen met behulp van SLAAC-routing naar alle apparaten achter de Edgerouter

Zodra ik het wat meer heb getest (vooral de statische V6-adressen, die er nog niet helemaal zijn), zal ik een nieuw onderwerp maken met mijn configuratie. Maar ik had het niet kunnen laten werken zonder je tutorials, bedankt
(sorry voor mijn nederlandse, engelse versie volgt)
George

++
Thanks a lot for this. I’m new to Freedom, and have just finished setting up v6 on my own Ubiquiti Edgerouter X SFP. Using an NTU, not the fibre SFP.

These instructions, along with these https://blog.daknob.net/setting-up-edgemax-devices-for-ote-ipv6/ helped me get V6 using SLAAC routing to all the devices behind the Edgerouter

Once I have tested it a bit more (particularly the static V6 addresses, which aren’t quite there yet), I will make a new topic with my config. But I wouldn’t have been able to get it working without your tutorials, thanks

George

2 likes

You’re very welcome George. I’m glad I could help you to get things working!

Ik krijg het helaas niet voor elkaar. :thinking:

Bij de SSH-methode loopt de zaak vast bij na het “service network restart”-commando. Ik krijg dan geen verbinding meer met de router.

En bij de GUI-methode krijg ik een “unknown error”…

Ik gebruik een Netgear R7000. Iemand ervaringen met dezelfde router?

Dan zal je een andere switch hebben en de VLAN’s anders moeten zetten dan voor een WDR4300. Kan je je oorspronkelijke /etc/config/network laten zien? Dan pas ik die voor je aan.

Dat is ontzettend fijn!

Dit is de default instelling van /etc/config/network:

config interface 'loopback'  
        option ifname 'lo'       
        option proto 'static'     
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdbf:74e5:6daf::/48'

config interface 'lan'
        option type 'bridge' 
        option ifname 'eth0.1'     
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'     
        option ifname 'eth0.2'
        option proto 'dhcp'   

config device 'wan_eth0_2_dev'
        option name 'eth0.2'
        option macaddr '****'     

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 5t'

(Ik ga ervan uit dat je FttH hebt, dus ik heb geen modem-interface of -VLAN ingesteld.)

Probeer hem eerst eens zo. Als dat lukt, doen we daarna Baby Jumbo Frames:


    config globals 'globals'
            option ula_prefix 'fdbf:74e5:6daf::/48'

    config interface 'loopback'  
            option ifname 'lo'       
            option proto 'static'     
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'

    config interface 'lan'
            option type 'bridge' 
            option ifname 'eth0.1'     
            option proto 'static'
            option ipaddr '192.168.1.1'
            option netmask '255.255.255.0'
            option ip6assign '60'

    config interface 'wan'
            option ifname 'eth0.6'
            option proto 'pppoe'
            option username 'fake@freedom.nl'
            option password '1234'
            option pppd_options 'debug'

    config switch
            option name 'switch0'
            option reset '1'
            option enable_vlan '1'

    config switch_vlan
            option device 'switch0'
            option vlan '1'
            option ports '1 2 3 4 5t'
    
    config switch_vlan
            option device 'switch0'
            option vlan '6'
            option ports '0t 5t'

Heb je wel VDSL met een modem dat je wilt bereiken, doe dan dit:

    config globals 'globals'
            option ula_prefix 'fdbf:74e5:6daf::/48'

    config interface 'loopback'  
            option ifname 'lo'       
            option proto 'static'     
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'

    config interface 'lan'
            option type 'bridge' 
            option ifname 'eth0.1'     
            option proto 'static'
            option ipaddr '192.168.1.1'
            option netmask '255.255.255.0'
            option ip6assign '60'

    config interface 'modem'
            option ifname 'eth0.2'
            option proto 'static'
            option ipaddr '192.168.200.2'
            option netmask '255.255.255.0'
            option force_link '0'

    config interface 'wan'
            option ifname 'eth0.6'
            option proto 'pppoe'
            option username 'fake@freedom.nl'
            option password '1234'
            option pppd_options 'debug'

    config switch
            option name 'switch0'
            option reset '1'
            option enable_vlan '1'

    config switch_vlan
            option device 'switch0'
            option vlan '1'
            option ports '1 2 3 4 5t'

    config switch_vlan
            option device 'switch0'
            option vlan '2'
            option ports '0 5t'    

    config switch_vlan
            option device 'switch0'
            option vlan '6'
            option ports '0t 5t'
1 like

Kevin, ik ben je zéér erkentelijk: het werkt! :man_cartwheeling:

2 likes

Mooi zo. Dan kan je nu nog even met de MTU spelen. (Dus die voor het eth0-device en WAN op 1508 zetten en voor LAN en eventueel Modem - indien je die interface gemaakt hebt - op 1500.)

Het loopt als een trein. Heel fijn!

Denk je dat een vergelijkbare instelling op een DD-WRT mogelijk is?

Ja, vrijwel zeker. Ik ken DD-WRT alleen niet uit m’n hoofd. Maar deze instellingen zijn universeel, alleen de configuratie-opties en -bestanden zijn wellicht net iets anders.

P.S. Om je MTU te testen doe je het volgende:

ping6 -M do -s 1452 freedom.nl
ping4 -M do -s 1472 freedom.nl

In allebei de gevallen moet je dan niet local error: message too long terugkrijgen.

1 like

Dank voor de toevoeging. Ik krijg helaas wel de melding local error: message too long.

Heb je je /etc/config/network als volgt?

    config globals 'globals'
            option ula_prefix 'fdbf:74e5:6daf::/48'

    config device
            option name 'eth0'
            option mtu '1508'

    config interface 'loopback'  
            option ifname 'lo'       
            option proto 'static'     
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'

    config interface 'lan'
            option type 'bridge' 
            option ifname 'eth0.1'
            option mtu '1500'
            option proto 'static'
            option ipaddr '192.168.1.1'
            option netmask '255.255.255.0'
            option ip6assign '60'

    config interface 'wan'
            option ifname 'eth0.6'
            option mtu '1508'
            option proto 'pppoe'
            option username 'fake@freedom.nl'
            option password '1234'
            option pppd_options 'debug'
...

Indien je ook een modem-interface hebt, zet je daar ook option mtu '1500'.

Let op dat als je een modem hebt, dat hij wel Jumbo Frames ondersteunt. Een NTU doet dat sowieso.

Ja, ik heb deze instellingen gebruikt.

(Dus die voor het eth0-device en WAN op 1508 zetten en voor LAN en eventueel Modem op 1500.)

Een kleine opmerking over het “eventueel”. Volgens mij is dat dus belangrijk, omdat je anders een advies krijgt om MTU 1508 te gebruiken wat betekend dat er fragmentatie op de router nodig is. Je wil nu juist dat clients 1500 gebruiken voor verkeer dat over de tunnel naar “buiten” moet (= internet). In wat experimenten die ik destijds gedaan heb kwam naarvoren dat de path discovery en dat soort grappen in OpenWRT gebaseerd word op de interface MTU.
Het meest ideale is natuurlijk als de client direct een fragmentatiegrootte gebruikt waarmee alle routers op 't pad naar de server overweg kunnen, dus ook de OpenWRT edge die de tunnel naar Freedom heeft.

Ik geef toe dat dit verhaal een beetje vaag klinkt hier en daar, MTU is een wat beladen onderwerp op het interwebs, maar een verkeerde instelling is vaker pijnlijker dan je in eerste instantie zou denken, zoals iemand al aangaf met bv edns size op je resolver.

Met ‘eventueel’ bedoel ik dat je alleen een ‘modem’-interface hebt als je VDSL hebt. Met FttH is die hele interface er niet en kan je er de MTU ook niet van instellen. (Of je moet een mediaconverter met webinterface hebben en daarvoor een extra interface gebruiken die je toevallig ‘modem’ hebt genoemd.)

De modem-interface wordt alleen gebruikt om de webconfig en SSH-server van het modem te benaderen. Niet het internet; dat gaat via PPPoE en staat los van de untagged interface op VLAN 2. In het ergste geval kan je dus je modem-config niet bereiken als je die interface per ongeluk op 1508 zet.

Kan je met logread eens teruglezen wat de negotiation van pppd doet?

Onder de regel pppd: Connect: pppoe-wan <--> eth0.6 zou je mru xxxx moeten zien, een aantal keren. Wat heb je daar?

Mon Nov 2 14:50:47 2020 daemon.debug pppd[3911]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0xbf90eaa2>]
Mon Nov 2 14:50:47 2020 daemon.debug pppd[3911]: rcvd [LCP ConfReq id=0xd4 <mru 1492> <magic 0x5ae32a51>]
Mon Nov 2 14:50:47 2020 daemon.debug pppd[3911]: sent [LCP ConfAck id=0xd4 <mru 1492> <magic 0x5ae32a51>]
Mon Nov 2 14:50:47 2020 daemon.debug pppd[3911]: rcvd [LCP ConfAck id=0x1 <mru 1492> <magic 0xbf90eaa2>]