Installatie IPTV op OpenWRT router

Ik probeer IPTV van Freedom aan de gang te krijgen op een OpenWRT router. Hiervoor volg ik de instructies op Algemene instellingen | Freedom

Wat ik ook probeer, ik krijg het IGMP gedeelte niet goed aan de praat. Heeft iemand IPTV in combinatie met een OpenWRT werkend? Zou je misschien de relevante delen van de bestanden /etc/config/igmpproxy en /etc/config/firewall willen delen? Andere tips zijn ook welkom.

Ik heb ooit voor XS4ALL de boel aan de praat gekregen, en onder het kopje IPTV gedocumenteerd: [OpenWrt Wiki] ISP Configurations
Lijkt erop dat Freedom IPTV soortelijk hetzelfde lijkt te werken, misschien dat je hier iets verder mee kunt komen? Ik heb zelf geen TV abbo, dus kan je verder niet helpen.

Ik ben hier inderdaad ook wel benieuwd naar, maar ook ik heb en wil nergens TV-abonnementen, dus ik kan het ook niet testen.

Maar goed, wat ik denk dat kan werken, is het volgende. Ik kan alleen niets beloven.

/etc/config/network:

config interface 'iptv'
        option ifname 'eth0.4'
        option proto 'dhcp'
        option defaultroute '0'
        option peerdns '0'
        option vendorid 'IPTV_RG'

[...]

config route
        option target '10.10.0.33'
        option netmask '255.255.255.255'
        option gateway '10.10.12.1'
        option interface 'lan'

config route
        option target '185.24.175.0'
        option netmask '255.255.0.0'
        option gateway '10.10.12.1'
        option interface 'lan'

config route
        option target '185.41.48.0'
        option netmask '255.255.255.0'
        option gateway '10.10.12.1'
        option interface 'lan'

/etc/config/firewall:

config zone
        option name 'iptv'
        option network 'iptv'
        option device 'eth0.4'
        option family 'ipv4'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'

config forwarding
        option dest 'iptv'
        option src 'lan'

[...]

config rule
        option name 'Accept-IGMP-from-IPTV'
        option src 'iptv'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Forward-multicast-from-IPTV'
        option src 'iptv'
        option proto 'udp'
        option family 'ipv4'
        option target 'ACCEPT'
        option dest_ip '224.0.0.0/4'
        option dest 'lan'

/etc/config/igmpproxy:

config igmpproxy
        option quickleave '1'
        option verbose 'maximum'

config phyint
        option network 'iptv'
        option direction 'upstream'
        list altnet '0.0.0.0/0'

config phyint
        option network 'lan'
        option direction 'downstream'