Hoort de internetverbinding meteen na installatie te werken?

Vanochtend heeft een monteur mijn Freedom-internetaansluiting geïnstalleerd. In de mail die ik van tevoren kreeg stond dit:

Uw telecomaanbieder activeert uw verbinding als de aansluiting op het glasnetwerk (stap 1) is gerealiseerd. Na deze activatie kunt u gebruikmaken van uw afgenomen diensten. Voor vragen hierover kunt u contact opnemen met uw telecomaanbieder.

Echter, de monteur zei dat ik direct mijn router zou moeten kunnen inpluggen en dat het dan zou moeten werken. Maar helaas, mijn router (een Linksys EA6400) zegt dat er geen verbinding is:

image

Hoe lang duurt het normaal gesproken voordat een verbinding geactiveerd wordt? Met andere woorden, wanneer weet ik of er iets fout is, of dat ik gewoon wat meer geduld moet hebben?

Gebruik je je router als modem? Of zit er nog een Fritzbox tussen?

Hoi

Heb je DSL? Wat voor een modem gebruik je en hoe is het geconfigureerd?
Heb je glas? Hoe is je router geconfigureerd?
Voor internet heb je PPPoE via VLAN 6 nodig. Kan je vast wel ergens instellen.

Vr.Gr,
Rob

Er zit geen Fritzbox tussen.

Heb je DSL? Wat voor een modem gebruik je en hoe is het geconfigureerd?
Heb je glas? Hoe is je router geconfigureerd?
Voor internet heb je PPPoE via VLAN 6 nodig. Kan je vast wel ergens instellen.

Als het goed is hebben wij glasvezel; ik gebruik een Linksys EA6400. Misschien voor wat context: ik heb tot nu toe altijd een kabel in mijn router gestopt en had vervolgens internet, dus ik ging ervan uit dat zoiets nu ook zou kunnen. Dat was wel altijd met gedeelde internetaansluitingen in huurhuizen. Ik weet hier helaas dus allemaal niet zoveel vanaf, dus misschien is mijn aanname dat ik geen Fritzbox nodig zou hebben verkeerd?

Ik zal in ieder geval als ik weer in de buurt ben eens rondneuzen in de instellingen. Jullie vragen hebben me in ieder geval al op het juiste spoor gezet dat ik zelf dingen moet instellen, en daarmee op deze pagina - daar kom ik hopelijk verder mee. Binnenkort meer :slight_smile:

Met die gedeelde netwerkverbindingen zal het ongetwijfeld DHCP geweest zijn (waarschijnlijk dan dubbel NAT op IPv4 en een prefix delegation op IPv6), zonder 802.1Q.

Dat is heel anders dan de uplink bij Freedom. Dat is PPPoE in plaats van DHCP (met DHCPv6-PD binnen de PPPoE-tunnel voor IPv6) en vereist dat je je traffic op de WAN-interface voorziet van 802.1Q-tags op VLAN 6.

Ik heb ooit een topic geschreven over hoe je je eigen OpenWrt-router configureert: [Handleiding:] configureren van OpenWrt

De instellingen zijn voor andere routerbesturingssystemen niet anders.

Oef, ik begin bang te worden dat ik heb onderschat hoe doenlijk het voor mij is mijn eigen router te gebruiken / of mijn router uberhaupt wel geschikt is. Hij draait (helaas!) geen OpenWRT, en lijkt niet de optie te hebben de benodigde instellingen te configureren. Specifiek: ik kan als Mode PPoE instellen, en een gebruikersnaam en wachtwoord invullen, maar ik zie bijv. geen referenties aan VLAN, PPP authenticatie, MTU-waarde (ik kan een “size” instellen, maar niet groter dan 1492), MSS clamping:

Het voelt als opgeven, maar ik begin te denken dat ik toch maar zo’n Fritzbox moet bestellen :frowning:

Zeker geen FritzBox bestellen. Het lukt je heus wel.

MTU 1492 is op zich geen probleem als je MSS Clamping aanzet. 1500 is mooier, maar lang niet elke router ondersteunt RFC4638.

IPv4 zet je op PPPoE met iets als username en password (maakt niet uit wat, hoeft niet je echte account te zijn). IPv6 zet je op Automatic / Native / DHCPv6 (wellicht kan je een screenshot van dat tabblad laten zien).

Dan moet je alleen nog ergens VLAN-tags / 802.1Q instellen, en de WAN-interface op VLAN 6 zetten. Meer is het niet.

Kijk hier eens naar: Officiële ondersteuning van Linksys - Hoe VLAN configureren op uw Linksys Smart Wi-Fi Router

Ik denk dat je “Internet” op ID 6, Tagged, Priority 0 moet zetten.

1 like

Zeker geen FritzBox bestellen. Het lukt je heus wel.

Haha, dank voor de aanmoediging, en de hulp! Wordt zeer gewaardeerd :slight_smile:

MTU 1492 is op zich geen probleem als je MSS Clamping aanzet. 1500 is mooier, maar lang niet elke router ondersteunt RFC4638.

OK, dus als ik het goed begrijp is dat invoerveld gelabeld “Size” waar ik MTU op 1492 kan invoeren? Alleen geen idee hoe ik dan MSS Clamping aanzet :confused:

IPv4 zet je op PPPoE met iets als username en password (maakt niet uit wat, hoeft niet je echte account te zijn).

Mooi, dat kan ik.

IPv6 zet je op Automatic / Native / DHCPv6 (wellicht kan je een screenshot van dat tabblad laten zien).

Dat lijkt ook te kunnen:

(6rd tunnel kan ik op “Disabled”, “Automatic” en “Manual” zetten, waarbij “Manual” de onderste vier velden activeert.)

Dan moet je alleen nog ergens VLAN-tags / 802.1Q instellen, en de WAN-interface op VLAN 6 zetten. Meer is het niet.

Kijk hier eens naar: Officiële ondersteuning van Linksys - Hoe VLAN configureren op uw Linksys Smart Wi-Fi Router

Maar hier zit het probleem; ik heb het vermoeden dat mijn router de juiste instellingen helemaal niet ondersteunt? In de screenshots in de handleiding die je deelde zie ik een tabje “VLAN”, maar in mijn interface zie ik die helemaal niet… En daarmee dus ook geen manier om VLAN-tags in te stellen, en (denk ik) ook niet om de WAN-interface op VLAN 6 te zetten. De handleiding zegt ook:

OPMERKING: Deze functie wordt mogelijk niet ondersteund in sommige Linksys Smart Wi-Fi Routers.

Hier screenshots van de andere tabs, voor het geval je daar kan zien waar ik wel de juiste instellingen zou kunnen invoeren:

(Ik weet niet wat allemaal gevoelige informatie is, dus ik heb redelijk liberaal dingen uitgeveegd.)

Ik zag wel gisteren dat DD-WRT welliicht wel mijn router ondersteunt, dus ik zou nog kunnen proberen dat te installeren, maar dan ben ik wel heel erg aan het yak shaven… En als het probleem bij de hardware ligt, zal dat natuurlijk niet helpen.

De kans dat hardware geen 802.1Q ondersteunt is echt nihil. Als het niet beschikbaar is, is het een kunstmatige beperking in software. De goedkoopste GL.iNet-routers van AliExpress kunnen dat al (met OpenWrt dan).

Dus als je firmware geen VLAN’s ondersteunt zal je inderdaad DD-WRT moeten installeren. (Nu zou ik altijd open source firmware aanraden boven stock firmware, aangezien je dan ook daadwerkelijk kunt verifiëren dat het veilig is en niets doet zonder dat je weet wat het doet, aangezien je de broncode kunt auditen.)

OpenWrt ondersteunt volgens mij jouw router niet vanwege de Broadcom WiFi-chipset. Maar qua configuratie lijkt DD-WRT wel behoolijk op OpenWrt als het goed is, dus je kunt met mijn handleiding dan grotendeels uit de voeten.

Ik denk dat het heel verstandig is af te stappen van de standaard firmware van deze router. De laatste update is van 2017 (!). In de release notes, zie ik ook geen enkele melding van vlan. Je zou kunnen proberen de laatste update erop te zetten, al denk ik dat het onverstandig is om router als poortwachter van je netwerk te gebruiken die niet meer wordt onderhouden.

Ik denk inderdaad dat wat @Kevin zegt je enige optie is. De instructies om dit te doen zijn redelijk duidelijk:
https://wiki.dd-wrt.com/wiki/index.php/Linksys_EA6400

Maar ik kan mij voorstellen dat je daar niet op zit te wachten.

Hmm, ik moet zeggen dat het idee van open source firmware gebruiken me ook wel aanstaat, dus als jullie verwachten dat hardware het probleem niet is, wordt dat wel een aantrekkelijk idee. Enige mogelijke complicatie is dat ik een verwijzing zie naar CFEEdit.exe (en sowieso dat de instructies gericht lijken te zijn op Windows), terwijl ik op Fedora zit, dus daar moet ik dan nog iets op vinden. Ik ga ernaar kijken, dank voor de pointers!

Volgens mij is die stap alleen nodig als je ooit terug wilt naar je stock firmware, wat om allerlei redenen niet voor de hand liggend is. (Het werkt niet met VLAN’s en het is 5 jaar oud en zo.)

Desalniettemin is dit wellicht de moeite waard om te lezen: [OpenWrt Wiki] Changing CFE defaults

En als het een binary is, werkt iedere hex editor waarschijnlijk gewoon.

Even terug naar de basis:

Heeft de monteur wel gecontroleerd en bevestigd dat hij iets werkend heeft opgeleverd aan jou?

Als die router geen VLAN’s afhandelt gaat het echt gegarandeerd niet werken. En dat doen ze niet magisch; dat moet je echt instellen.

Eerste succes: mijn router draait nu DD-WRT! Mijn oude internetverbinding werkt, dus dat is een goed teken. Morgen nog maar eens proberen met Freedom te verbinden. Heel erg bedankt voor de aanmoeding, dit is tof!

Oh, en:

Heeft de monteur wel gecontroleerd en bevestigd dat hij iets werkend heeft opgeleverd aan jou?

Hij heeft geen laptop eraan gehangen en verbinding gemaakt met het internet, nee. Ik heb daar ook niet naar gevraagd, omdat ik niet verwachtte dat hij dat zou kunnen, omdat ik geen router erbij had aangevraagd.

1 like

Hmm OK, Ik heb nu geprobeerd @Kevins handleiding te volgen, maar ik heb een beetje moeite met het vinden van de equivalente opties van OpenWRT in DD-WRT. Hieronder wat screenshots van wat ik denk dat de relevante schermen zijn, en hoe ik ze nu heb ingesteld.

Ik kan PPPoE instellen en een gebruikersnaam en wachtwoord ingeven:

En hier wat ik zie als ik “Advanced settings” aanzet:

Ik denk dat dit het gedeelte is voor het kopje “VLAN’s instellen”, alleen zie ik in de handleiding geen kopjes “WAN” en 1, 2, 3 en 4.

En dan is er nog dit scherm, wellicht ook relevant:

Als iemand me nog wat verder in de juiste richting zou kunnen wijzen, zou ik dat zeer waarderen :slight_smile:

Kan je ook SSH’en naar je router en eens cat /etc/config/network doen en daar de output van posten? En ook van ip addr show wellicht?

Ik ben niet handig met GUI’s, maar op de command line kan ik snel genoeg zien of je interfaces goed staan.

Afgaande van je switch config zou ik ervan uitgaan dat de WAN-poort op VLAN 6 tagged staat, dus dat ziet er goed uit, maar op dat laatste screenshot dat je post zie ik VLAN-tagging weer apart staan…

Overigens zie ik dat LAN4 op VLAN 1 tagged staat, maar dat lijkt me niet te kloppen. LAN-poorten moet je niet taggen op VLAN 1; alleen WAN op VLAN 6.

Dit is wellicht ook interessant om te bekijken: Eigen router met DD-WRT configureren voor internet | KPN Community

(De configuratie voor Freedom en KPN is hetzelfde namelijk.)